LoRa Sensoren anbinden - Workshop?

Hi, ich stelle mich leider etwas zu dämlich bei der Anbindung von Sensoren (z.B. DS18B20 am LoRa Radio Node v1.0 IOTMCU) in das LORA Netzwerk an. GW über Raspberry läuft und ist angemeldet. Gibt es bei euch vielleicht irgendwann mal so etwas wie eine Einführung ? Wäre sehr daran interessiert und würde ggf. auch den weiten weiten Weg nach Potsdam auf mich nehmen :slight_smile:

Ich hab mal das Thema hierher verschoben. Dann hat es einen eigenen Platz.
@Thias oder @christoph , @Sven (?) habt ihr Lust mal einen Workshop dazu zu machen?

1 Like

Ich denke gerade für den DS18B20 hält das Internet massig Anleitungen und Beispiele bereit, wie man den mit Arduino anspricht und ausließt. LoRa ist dann meist etwas spezieller, je nach der verwendeten LoRa Bibliothek und Hardware. Ich plane keinen Workshop dazu.

Den DS18B20 über Arduino auszulesen hatte ich hinbekommen. Am Arduino angeschlossene DS18B20 und LORA Modul (SX1276) zusammen “spielen” zu lassen, jedoch nicht. Generelle Frage von mir ist da, wie bekomme ich “Nutzdaten in Form von Sensordaten” übertragen. GW funktioniert und das LORA Arduino Modul ist hier https://www.thethingsnetwork.org/ angemeldet und sichtbar. (wenn eingeschaltet)
Und nein, ein funktionierendes Beispiel habe ich auch nach monatelanger Suche nicht gefunden.

2 Beiträge wurden in ein neues Thema verschoben: LoraWan Treff - Terminfindung

Ich nutze die MCCI LoRaWAN LMIC Library [1]. Unter dem Link findest du auch Beispiele. Es gibt dann zusätzlich die MCCI Arduino LoRaWAN Library [2]. Die ist dann als Wrapper der LMIC-Bibliothek mehr high level.

[1] GitHub - mcci-catena/arduino-lmic: LoraWAN-MAC-in-C library, adapted to run under the Arduino environm
[2] GitHub - mcci-catena/arduino-lorawan: User-friendly library for using arduino-lmic with The Things Net

Hallo zusammen

Ich bin jetzt am Ende mit meinem Latein. Ich habe die LoRa-Gateways auf V3 umgestellt. Sie sind beide aktiv und der in der Feuerbachstr. wird auch aktiv genutzt - es gibt nachts Pakete, die sind definitiv nicht von mir.

Jedenfalls habe ich mir ein frisches Board genommen, eine neue Application und End device registriert. ABER:

Ich sehe die Pakete im Log des Gateway UND in der thethingsnetwork Console beim entsprechenden Gateway. Unter der Aplication steht aber “No activity yet”.

gateway-rak
gateway-ttn
ttn-enddevice

Kann mir jemand einen Tipp geben, wo ich nachschaue wo die Daten verloren gehen?

Nutze auch die “MCCI LoRaWAN LMIC Library”

Schöne Grüße
Frank

Warum ist AppEUI leer? Ich denke so kann keine Zuordnung der Daten zu deiner TTN App geschehen.

Hmm,

ich bin bisher davon ausgegangen, bei ABP brauche ich nur
DeviceAddress, Network Session Key und Application Session Key

Gruß Frank

Die AppEUI war es nicht. Aber der Tipp mit den IDs war hilfreich. In den ganzen Testscripten habe ich mich wohl verlaufen und falsche IDs kopiert. Jedenfalls bin ich jetzt einen Schritt weiter und schraube am payload decoder - Dann fehlt nur noch der Server hier für die Integration und selbige in thethingsnetwork. Und der Kreis schließt sich.

Vielen Dank
Frank

1 Like

Kurze Rückmeldung,

Das Problem war eigentlich nur fehlende Ruhe und Geduld. Jedenfalls gehen die Daten jetzt tatsächlich vom Board via Thethingsnetwork in meinen eigenen Server hier unterm Tisch. Im Moment ist es nur ein simpler Counter, aber das schlimmste ist damit überstanden. Jetzt kommen die Sensoren wieder dran.

Sensor → LoRa Board → Gateway → ttn → http auf eigener Server (-> openSensemap)

Gruß Frank

1 Like